contactSave 备份手机通讯录

函数功能:

将手机的联系人信息备份到 TC 服务器(电脑)的 “tcbr/contacts” 文件夹中。
在 Total Control 7.0.0 及以后版本支持通讯录备份为 xls,xlsx格式的文件。

对应JS API:
contactSave(path)
contactSave(path,fields)
是否支持多设备:

不支持

适用版本:

Total Control 6.9.0 及以后版本

请求方式:POST
http://IP:8090/TotalControl/v1/devices/:device/contacts?token=:token&type=import
//Total Control 7.0.0 及以后版本支持下列 URL
http://IP:8090/TotalControl/v1/devices/:device/contacts?token=:token&type=import&file_name=:file_name&fields=:fields
参数说明:
参数名 类型 必选 描述
IP string Y 访问 Total Control 服务器的 IP 地址
token string Y Total Control TOKEN
type string Y 操作类型,手机的联系人信息备份到 TC 服务器,固定值:import
file_name string N 导出的文件保存名称,支持格式: .json、.xls、.xlsx
fields 数组 N 保存指定的字段,如果需要保存联系人部分字段,必须包含 name 和一个电话号码字段,例如,如果我们想保存 company 字段,fields 值为:['name','phone1','company']
JSON:

导出的通讯录联系人信息是 json 格式,如下所示:


{
	"version": "1.0.0.0",
	"data": [{
			"contactId": "16",
			"displayName": "成都杰华科技",
			"phone": [{
				"phoneNumber": "028 8533 2200",
				"phoneType": "2"
			}],
			"email": [],
			"organization": [],
			"iconBytes": ""
		},
		{
			"contactId": "2",
			"displayName": "华为客服",
			"phone": [{
				"phoneNumber": "4008308300",
				"phoneType": "2"
			}, {
				"phoneNumber": "10086",
				"phoneType": "1"
			}],
			"email": [{
				"emailValue": "mobile@huawei.com",
				"emailType": "1"
			}],
			"organization": [],
			"iconBytes": ""
			}]
}
EXCEL:

导出的通讯录联系人信息是 EXCEL 格式,导出的 excel 文件首行由下列字段组成:
name、phone1、phoneType1、phone2、phoneType2、phone3、phoneType3、email1、emailType1、email2、emailType2、company、title、iconBytes;
下图为导出通讯录联系人所以信息:


excel 表格首行字段意思如下:
name: 联系人姓名
phone1、phone2、phone3 : 联系人电话号码
phoneType1、phoneType2、phoneType3: 电话号码类型

1 表示住宅电话
2 表示手机号码
3 表示单位电话
4 表示单位传真
5 表示住宅传真
email1、email2: 电子邮箱
emailType1、emailType2: 邮箱类型,其中
1 表示私人邮箱
2 表示单位邮箱
company: 单位名称
title: 职位
iconBytes: 联系人头像,这里用的 base64 表示。

响应参数:

Total Control 提供的 REST API 响应格式都是 JSON ,返回值通常由关键字 "status" 和 "value" 组成,
status: 接口执行成功与否
value: 执行接口的返回信息
但是该接口的返回值由关键字 "status" 和 "file_url" 组成。

(一)执行接口成功的返回字段说明

字段 类型 描述
status boolean 执行接口成功,则返回:true
file_url string 手机的联系人信息备份到 TC 服务器(电脑)的 “tcbr/contacts” 文件夹中,例如:%AppData%\TotalControl\v1\storage\tcbr\contacts 目录中。
你可以在浏览器中输入 file_url "http://127.0.0.1:8090/TotalControl/v1/storage/tcbr/contacts/sigma_mobile1-2018-59-31-17-59-02.json" 打开这个链接,点击"右键"--"另存为",存储在本机某个位置。
或者,你可以用脚本的形式,下载这个文件。


返回示例:

{
    "file_url":"http://127.0.0.1:8090/TotalControl/v1/storage/tcbr/contacts/HUAWEI-HUAWEI P7-L07-2018-29-02-14-29-00.json",
    "status":true
}

(二)执行接口返回 HTTP 状态码为 200,但是结果有误的返回字段说明

字段 类型 描述
status object 执行接口失败,则返回:null 对象
value string 返回失败的具体信息


返回示例:

{
    "status":null,
    "value":"......"
}
请求示例:
http://localhost:8090/TotalControl/v1/devices/device@230441652/contacts?type=import&token=tH3Q1p9aMjJoG3eP
示例:备份设备上的联系人到 Total Control 服务器,只备份联系人电话号码,联系人名称,联系人的工作单位几个字段,并保存为 mycontact.xls

注意:下列示例是通过本机访问 Total Control 服务器,所以 IP 都是用的 "localhost"。

RingoJS 请求示例:

可以复制下面的代码,在 Total Control 的脚本终端中执行,也可以保存为后缀为 js 的文件, 例如:example.js,在Total Control 执行器中执行。

//导入一些 ringoJS 的包
var {request} = require('ringo/httpclient');
var base64 = require('ringo/base64');
//将用户名密码编码,'sigma:3D391497'是用户名和密码,在Total Control系统设置里面可以看到
var userpass = base64.encode('sigma:3D391497');

//第一步:获取 Total Control 脚本开发所用的开发 token
var gettoken = request({
    method: 'GET',
    url: 'http://localhost:8090/TotalControl/v1/login',
    headers: {'Authorization': userpass}
	});
//将获取的响应内容转换成json对象
var ret_token = eval('(' + gettoken.content + ')'); 
var token = ret_token.value.token; 
print("//获取 token 的值为:" + token);

//第二步:获取当前主控设备 ID 值
var getdevice = request({
    method: 'GET',
    url: 'http://localhost:8090/TotalControl/v1/devices/main?token=' + token
	});
var device = eval('(' + getdevice.content + ')').id; 
print("//获取到设备的 ID:"+ device);

//第三步:备份手机通讯录
var ret = request({
    method: 'POST',
    url: 'http://localhost:8090/TotalControl/v1/devices/'+ device + '/contacts',
    data: {
	"token": token,
	"file_name": "mycontact.xls",
	"fields": "['name','phone1','company']",
	"type": "import"
	}
	});
print(ret.content);
温馨提示:
获取 Total Control 脚本开发所用的开发 token 请看这里
获取主控设备 id 值 请看这里

RingoJS 示例运行结果:

成功,则返回:

//获取 token 的值为:m195zZEgY91PMcbo
//获取到设备的 ID:device@230441652
{
    "file_url":"http://127.0.0.1:8090/TotalControl/v1/storage/tcbr/contacts/mycontact.xls",
    "status":true
}
易语言请求示例:

温馨提示,关于易语言的更多信息,请看:
如何安装易语言
学写第一个易语言程序
如何使用易语言控制一台设备
如何使用易语言控制多台设备


.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 base64, 文本型
.局部变量 token, 文本型
.局部变量 device, 文本型
.局部变量 j_token, 类_json, , , 用来解析获取 token 的 json
.局部变量 j_dev, 类_json, , , 用来解析获取设备ID 值的 json
.局部变量 j_ret, 类_json, , , 用来解析 REST API 接口的json
.局部变量 bool, 逻辑型
.局部变量 bool_dev, 逻辑型
.局部变量 bool_ret, 逻辑型
.局部变量 status, 文本型

base64 = 到文本 (编码_BASE64编码 (到字节集 (“sigma:3D391497”)))
输出调试文本 (“将用户名和密码组装成 sigma:3D391497 进行 base64 编码生成的字符串为: ” + base64)
bool = j_token.解析 (到文本 (网页_访问_对象 (“http://localhost:8090/TotalControl/v1/login”, 0, , , , “Authorization:” + base64, , , , , , , , , )))
.如果 (bool)
    输出调试文本 (“第一步,获取 token,返回值为:” + j_token.取数据文本 ())
    token = j_token.取通用属性 (“['value'].token”)
    输出调试文本 (“获取的 token 值为: ” + token)
    bool_dev = j_dev.解析 (编码_utf8到gb2312 (到文本 (网页_访问_对象 (“http://localhost:8090/TotalControl/v1/devices/main?token=” + token, 0))))
    .如果 (bool_dev)
        输出调试文本 (“第二步,获取设备 ID 值,返回值为:” + j_dev.取数据文本 ())
        device = j_dev.取通用属性 (“['id']”)
        输出调试文本 (“获取的设备 ID 值为: ” + device)
        bool_ret = j_ret.解析 (编码_utf8到gb2312 (到文本 (网页_访问_对象 (“http://localhost:8090/TotalControl/v1/devices/” + device + “/contacts?type=import&file_name=mycontact.xls&fields=['name','phone1','company']&token=” + token, 1))))
        .如果 (bool_ret)
            输出调试文本 (“第三步,备份手机通讯录,返回值为: ” + j_ret.取数据文本 ())
            status = j_ret.取属性对象 (“status”)
            .如果 (status = “true”)
                输出调试文本 (“恭喜你,成功了!”)
            .否则
                输出调试文本 (“不好意思,失败了!”)
            .如果结束

        .否则
            输出调试文本 (“该 API 执行失败”)
        .如果结束

    .否则
        输出调试文本 (“获取设备 ID 值失败”)
    .如果结束


.否则
    输出调试文本 (“获取 token 失败”)
.如果结束

易语言代码运行结果:

成功,则返回:

* 将用户名和密码组装成 sigma:3D391497 进行 base64 编码生成的字符串为: c2lnbWE6M0QzOTE0OTc=
* 第一步,获取 token,返回值为:{"status":true,"value":{"token":"ad4e9cc8jQKyNO18"}}
* 获取的 token 值为: ad4e9cc8jQKyNO18
* 第二步,获取设备 ID 值,返回值为:{"id":"device@230441652"}
* 获取的设备 ID 值为: device@230441652
* 第三步,备份手机通讯录,返回值为: {"file_url":"http://127.0.0.1:8090/TotalControl/v1/storage/tcbr/contacts/mycontact.xls","status":true}
* 恭喜你,成功了!


注意事项:
如果返回值为 {"status": false},可能是 TC 没有操作手机联系人的权限。
提供下面两种解决方法:
(一)如果您在执行该 API 的时候,手机屏幕弹出下图中的对话框时,点击图中的 "允许" 按钮。


(二)打开手机的设置应用,进入手机的设置应用界面,找到“权限管理”或者 “应用管理“ 里面的 TC 应用程序,跟联系人,通讯录相关的权限,请都设置成 "允许"。